1. 首頁
  2. 股市資訊

「大智慧」神獒均線主圖指標公式

if DIspstATUS=2 then aaa:=BARPOS;
if DISpsTATUS=1 then bbb:=BARPOS;
ddd:=aaa-bbb;
ee:=hhv(h,ddd);
MSTATUS:=BARSTATUS=2;
MA5:MA(C,5),PREcis2;
ma10:MA(C,10),PRECIS2;
Ma30:MA(C,30),PRECIS2;
Ma60:MA(C,60),PRECIS2,lineTHICK2;
MA125:MA(C,125),ColorFFFF00,PRECIS2,LINethICK2;
MA250:MA(C,250),PRECIS2,LINETHICK2;
i:=1;
IF MSTATUS and (MA5 > MA10 and MA10 > MA30 and MA5 > MA30) THEN BEGIN DRAWTEXTABS(0,i*16,短期均線多頭排列。股價高位謹防筑頂。中低位當股價向上突破5、10、30日均線,均線呈多頭排列是最佳買入時機。 ma5 > ma10 > ma30 ;),COLOrrED,alIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA5 < Ma10 and MA10 < MA30 and MA5 < MA30) THEN BEGIN DRAWTextabs(0,i*16,'短期均線空頭排列。股價高位謹防棄莊,賣盤涌出破位下跌。中低位當股價向下突破5、10、30日均線,均線呈空頭排列時,注意觀察股價所處箱體位置。' ma5 ' < ' ma10 ' < ' ma30 ';'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA30 > MA60 and MA30 > MA125 and MA60 > MA125) THEN BEGIN DRAWTEXTABS(0,i*16,中期均線多頭排列。注意股價突然下跌,當股價回檔至當前盤面30、60、125日任一均線獲得支撐,關注均線助漲,次日股價放量向上突破,是中長期最佳買入時機。 ma30 > ma60 > ma125 ;),COLORRED,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA30 < MA60 and MA30 < MA125 and MA60 < MA125) THEN BEGIN DRAWTEXTABS(0,i*16,'中期均線空頭列排。30、60、125日中長期均線下行呈空頭排列,注意箱體上下撐壓或無量空跌。 ' ma30 ' < ' ma60 ' < ' ma125 ';'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA60 > MA125 and MA125 > MA250 and MA60 > MA250) THEN BEGIN DRAWTEXTABS(0,i*16,長期均線多頭排列。即60,125,250日均線向上多頭排列。注意:當股價處于箱體頂部,所有均線多頭排列,股價反復震蕩不能突破,可能頂部即將形成。 ma60 > ma125 > ma250 ;),COLORRED,ALIGN0,LINETHICK1;
i:=i 1; END;
IF MSTATUS and (MA60 < MA125 and MA125 < MA250 and MA60 < MA250) THEN BEGIN DRAWTEXTABS(0,i*16,'長期均線空頭排列。即60,125,250日均線向下空頭排列。注意:當所有均線空頭排列的時候,股價處于箱體的一個次高位,中位,或箱體下沿,可能是階段底部的形成。 ' ma60 ' < ' ma125 ' < ' ma250 ';'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (croSS(MA5,MA10)) THEN BEGIN DRAWTEXTABS(0,i*16,短期5日10日均線金叉。注意觀察股價在箱體的位置,30日和其他均線是否成為股價上漲的阻力,或股價在高位的運行方向,判斷是反轉上漲還是下跌中途的小反彈。),COLORRED,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (CROSS(MA10,MA5)) THEN BEGIN DRAWTEXTABS(0,i*16,短期5日10日均線死叉。當股價反彈遭遇30日和其他均線的阻力形成死叉,可能是股價下跌中途的小反彈。高位區死叉,必須逃頂止損。),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (CROSS(C,MA125)) THEN BEGIN DRAWTEXTABS(0,i*16,今日股價上穿半年線。在半年線上方運行的個股被稱為強勢股。適合中小資金根據短線技術指標套利操作。 ),COLORFF00FF,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (CROSS(MA125,C)) THEN BEGIN DRAWTEXTABS(0,i*16,今日股價跌破半年線。在半年線下方運行的個股被稱為弱勢股。適合大資金進場吸籌操作。 ),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (CROSS(C,MA250)) THEN BEGIN DRAWTEXTABS(0,i*16,今日股價上穿年線。股票筑底后,股價經過反復震蕩洗盤上穿年線,予以鎖定跟蹤。 ),COLORFF00FF,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (CROSS(MA250,C)) THEN BEGIN DRAWTEXTABS(0,i*16,今日股價跌破年線。跌破年線,證明深度調整格局可能形成。如果后市股價繼續深跌,調整時間和空間難以預測。 ),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (CROSS(C,MA60) and CROSS(C,MA125) and CROSS(C,MA250)) THEN BEGIN DRAWTEXTABS(0,i*16,股價一陽穿三線。5、10、30日均線三線合一,股價一陽穿三線,向上反轉,可能變盤反轉在即。 ),COLORRED,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA30 > REF(MA30,1)) THEN BEGIN DRAWTEXTABS(0,i*16,30日均線趨勢向上。注意:如果股價在低位中位30日均線之上,圍繞另一條重要均線縮量橫盤,隨后5-10日均線金叉,所有均線向上呈多頭排列,是中長期績優牛股的搖籃。),COLORRED,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA30 > REF(MA30,1) AND MA30 < REF(MA30,1)*1.001) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均線趨勢走平。需觀察5日和10日均線方向,如30日均線發出趨勢向下信號,5日10日均線形成死叉,注意減倉或出貨。'),COLORFfcc66,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA30 < REF(MA30,1)) THEN BEGIN DRAWTEXTABS(0,i*16,'30日均線趨勢向下。關注股價所處箱體位置,如股價當前上漲或下跌時,則需觀察箱體阻力支撐位置。如果股價處于遠離30日均線位置,一般情況下股價反彈空間有限。'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA5 > REF(MA5,1)*1.015) THEN BEGIN DRAWTEXTABS(0,i*16,5日均線強勁向上。需觀察股價所處其他均線和箱體位置,如果收盤時股價突然跌破5日均線,則需觀察箱體下方支撐,提防空頭陷阱,股價轉向。),COLORRED,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA5 > REF(MA5,1) AND MA5 < REF(MA5,1)*1.005) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均線方向不明。當股價連續跌破5日均線和箱體下沿,導致股價方向開始向下,績優股應適當做空;股價在箱體內則需觀察股價下方的重要均線位置,可否獲得支撐。'),COLORYELLOW,ALIGN0,LINETHICK1;
i:=i 1;
END;
IF MSTATUS and (MA5 < REF(MA5,1)*0.985) THEN BEGIN DRAWTEXTABS(0,i*16,'5日均線快速向下,短線風險可能降臨。需結合其他均線運行方向分析,如果股價在一個大箱體中,則需觀察下方均線支撐,偌收盤前股價獲得支撐,5-10均線金叉并數日向上,則可順勢而為做多。'),COLORGREEN,ALIGN0,LINETHICK1;
i:=i 1;
END;
if DispSTATUS=2 then begin;
var100:=■所屬行業板塊:;
if inblock(電力)=1 then var100:=var100 電力。;
if inblock(電力設備)=1 then var100:=var100 電力設備。;
if inblock(電器)=1 then var100:=var100 電器。;
if inblock(電子信息)=1 then var100:=var100 電子信息。;
if inblock(房地產)=1 then var100:=var100 房地產。;
if inblock(紡織服裝)=1 then var100:=var100 紡織服裝。;
if inblock(鋼鐵)=1 then var100:=var100 鋼鐵。;
if inblock(工程建筑)=1 then var100:=var100 工程建筑。;
if inblock(供水供氣)=1 then var100:=var100 供水供氣。;
if inblock(化工)=1 then var100:=var100 化工。;
if inblock(化纖)=1 then var100:=var100 化纖。;
if inblock(機械)=1 then var100:=var100 機械。;
if inblock(計算機)=1 then var100:=var100 計算機。;
if inblock(建材)=1 then var100:=var100 建材。;
if inblock(交通工具)=1 then var100:=var100 交通工具。;
if inblock(交通設施)=1 then var100:=var100 交通設施。;
if inblock(教育傳媒)=1 then var100:=var100 教育傳媒。;
if inblock(旅游酒店)=1 then var100:=var100 旅游酒店。;
if inblock(煤炭石油)=1 then var100:=var100 煤炭石油。;
if inblock(釀酒食品)=1 then var100:=var100 釀酒食品。;
if inblock(農林牧漁)=1 then var100:=var100 農林牧漁。;
if inblock(其他行業)=1 then var100:=var100 其他行業。;
if inblock(汽車)=1 then var100:=var100 汽車。;
if inblock(汽配)=1 then var100:=var100 汽配。;
if inblock(券商)=1 then var100:=var100 券商。;
if inblock(商業連鎖)=1 then var100:=var100 商業連鎖。;
if inblock(石化)=1 then var100:=var100 石化。;
if inblock(通信)=1 then var100:=var100 通信。;
if inblock(外貿)=1 then var100:=var100 外貿。;
if inblock(醫藥)=1 then var100:=var100 醫藥。;
{概念股網-股票公式網站 www.gainiangu.com}
if inblock(儀電儀表)=1 then var100:=var100 儀電儀表。;
if inblock(銀行類)=1 then var100:=var100 銀行類。;
if inblock(有色金屬)=1 then var100:=var100 有色金屬。;
if inblock(運輸物流)=1 then var100:=var100 運輸物流。;
if inblock(造紙印刷)=1 then var100:=var100 造紙印刷。;
if inblock(其他制造業)=1 then var100:=var100 其他制造業。;
if inblock(安徽)=1 then var100:=var100 所屬地區:安徽。;
if inblock(北京)=1 then var100:=var100 所屬地區:北京。;
if inblock(福建)=1 then var100:=var100 所屬地區:福建。;
if inblock(甘肅)=1 then var100:=var100 所屬地區:甘肅。;
if inblock(廣東)=1 then var100:=var100 所屬地區:廣東。;
if inblock(廣西)=1 then var100:=var100 所屬地區:廣西。;
if inblock(貴州)=1 then var100:=var100 所屬地區:貴州。;
if inblock(海南)=1 then var100:=var100 所屬地區:海南。;
if inblock(河北)=1 then var100:=var100 所屬地區:河北。;
if inblock(河南)=1 then var100:=var100 所屬地區:河南。;
if inblock(黑龍江)=1 then var100:=var100 所屬地區:黑龍江。;
if inblock(湖北)=1 then var100:=var100 所屬地區:湖北。;
if inblock(湖南)=1 then var100:=var100 所屬地區:湖南。;
if inblock(吉林)=1 then var100:=var100 所屬地區:吉林。;
if inblock(江蘇)=1 then var100:=var100 所屬地區:江蘇。;
if inblock(江西)=1 then var100:=var100 所屬地區:江西。;
if inblock(遼寧)=1 then var100:=var100 所屬地區:遼寧。;
if inblock(內蒙古)=1 then var100:=var100 所屬地區:內蒙古。;
if inblock(寧夏)=1 then var100:=var100 所屬地區:寧夏。;
if inblock(青海)=1 then var100:=var100 所屬地區:青海。;
if inblock(山東)=1 then var100:=var100 所屬地區:山東。;
if inblock(山西)=1 then var100:=var100 所屬地區:山西。;
if inblock(陜西)=1 then var100:=var100 所屬地區:陜西。;
if inblock(上海)=1 then var100:=var100 所屬地區:上海。;
if inblock(深圳)=1 then var100:=var100 所屬地區:深圳。;
if inblock(四川)=1 then var100:=var100 所屬地區:四川。;
if inblock(天津)=1 then var100:=var100 所屬地區:天津。;
if inblock(西藏)=1 then var100:=var100 所屬地區:西藏。;
if inblock(新疆)=1 then var100:=var100 所屬地區:新疆。;
if inblock(云南)=1 then var100:=var100 所屬地區:云南。;
if inblock(浙江)=1 then var100:=var100 所屬地區:浙江。;
if inblock(重慶)=1 then var100:=var100 所屬地區:重慶。;
if inblock(3g)=1 then var100:=var100 3G概念;
if inblock(CDM項目)=1 then var100:=var100 CDM項目概念;
if inblock(h股)=1 then var100:=var100 H股概念;
if inblock(qfii持股)=1 then var100:=var100 QFII持股概念;
if inblock(ST)=1 then var100:=var100 ST概念;
if inblock(S板)=1 then var100:=var100 S板概念;
if inblock(奧運)=1 then var100:=var100 奧運概念;
if inblock(參股金融)=1 then var100:=var100 參股金融概念;
if inblock(成渝特區)=1 then var100:=var100 成渝特區概念;
if inblock(出口退稅)=1 then var100:=var100 出口退稅概念;
if inblock(次新股)=1 then var100:=var100 次新股概念;
if inblock(大訂單)=1 then var100:=var100 大訂單概念;
if inblock(大盤)=1 then var100:=var100 大盤概念;
if inblock(中盤)=1 then var100:=var100 中盤概念;
if inblock(小盤)=1 then var100:=var100 小盤概念;
if inblock(低價)=1 then var100:=var100 低價概念;
if inblock(低市凈率)=1 then var100:=var100 低市凈率;
if inblock(中價)=1 then var100:=var100 中價概念;
if inblock(定向增發)=1 then var100:=var100 定向增發概念;
if inblock(封閉基金)=1 then var100:=var100 封閉基金概念;
if inblock(高價)=1 then var100:=var100 高價概念;
if inblock(公募增發)=1 then var100:=var100 公募增發概念;
if inblock(股權改革)=1 then var100:=var100 股權改革概念;
if inblock(股權激勵)=1 then var100:=var100 股權激勵概念;
if inblock(股權投資)=1 then var100:=var100 股權投資概念;
if inblock(航天軍工)=1 then var100:=var100 航天軍工概念;
if inblock(滬深300)=1 then var100:=var100 滬深300概念;
if inblock(基金重倉)=1 then var100:=var100 基金重倉;
if inblock(節能環保)=1 then var100:=var100 節能環保概念;
if inblock(可轉債)=1 then var100:=var100 可轉債概念;
if inblock(農業龍頭)=1 then var100:=var100 農業龍頭概念;
if inblock(清欠)=1 then var100:=var100 清欠概念;
if inblock(權證)=1 then var100:=var100 權證概念;
if inblock(券商重倉)=1 then var100:=var100 券商重倉概念;
if inblock(社保重倉)=1 then var100:=var100 社保重倉概念;
if inblock(深成40)=1 then var100:=var100 深成40概念;
if inblock(數字電視)=1 then var100:=var100 數字電視概念;
if inblock(稅收優惠)=1 then var100:=var100 稅收優惠概念;
if inblock(送轉)=1 then var100:=var100 送轉概念;
if inblock(外資并購)=1 then var100:=var100 外資并購概念;
if inblock(網絡游戲)=1 then var100:=var100 網絡游戲概念;
if inblock(稀缺資源)=1 then var100:=var100 稀缺資源概念;
if inblock(預虧預減)=1 then var100:=var100 預虧預減概念;
if inblock(預盈預增)=1 then var100:=var100 預盈預增概念;
if inblock(整體上市)=1 then var100:=var100 整體上市概念;
if inblock(低市盈利)=1 then var100:=var100 低市盈利概念;
if inblock(新能源)=1 then var100:=var100 新能源概念;
if inblock(新材料)=1 then var100:=var100 新材料概念;
if inblock(新上海)=1 then var100:=var100 新上海概念;
if inblock(注資承諾)=1 then var100:=var100 注資承諾概念;
if inblock(中小板指)=1 then var100:=var100 中小板指概念;
end;
DRAWTEXTABS(10,160,var100),Color00FF00;
均線60角度:=atan((MA(C,60)/ref(MA(C,60),3)-1)*100)*180/3.14159;
均線125角度:=atan((MA(C,125)/ref(MA(C,125),3)-1)*100)*180/3.14159;
均線250角度:=atan((MA(C,250)/ref(MA(C,250),3)-1)*100)*180/3.14159;
DRAWTEXTABS(10,140,■60天均線角度: NUMTOSTRN(均線60角度,2) ),ColorFFFFFF;
DRAWTEXTABS(160,140,■125天均線角度: NUMTOSTRN(均線125角度,2) ),ColorFFFFFF;
DRAWTEXTABS(315,140,■250天均線角度: NUMTOSTRN(均線250角度,2) ),ColorFFFFFF;
DRAWTEXTABS(10,180,■當前機構評級: EXTRASTRING(評級)),LINETHICK1,Color00FF00;
DRAWTEXTABS(10,200,),LINETHICK1,Color80BEFF;
{箱體空間}
NN:= DISPSTATUS=2;
A1:=REF(high,3)=HHV(HIGH,2*3 1);
B1:=FIlteR(A1,3);
c1:=BACKSET(B1,3 1);
d1:=FILTER(C1,3);
A2:=REF(LOW,3)=Llv(LOW,2*3 1);
B2:=FILTER(A2,3);
c2:=BACKSET(B2,3 1);
D2:=FILTER(C2,3);
E1:=(REF(LLV(LOW,2*3),1) REF(HHV(HIGH,2*3),1))/2;
E2:=(HIGH LOW)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(close)=1;
L1:=(D2 AND NOT(D1 AND E1=E2));
X1:=REF(BARSlast(h1),1) 1;
F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLvbaRS(IF(L1,LOW,10000),X1));
G1:=F1>REF(F1,1);
I1:=BACKSET(G1,2);
LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
x2:=REF(BARSLAST(L2),1) 1;
F2:=BACKSET(L2 AND COUNT(H1,X2)>0,HHVBARS(IF(H1,HIGH,0),X2));
G2:=F2>REF(f2,1);
I2:=BACKSET(G2,2);
HD:=I2>REF(I2,1);
UU:=BACKSET(BARSTATUS,BARSLAST(LD) 1);
VV:=UU>REF(UU,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1) 2);
XX:=WW>REF(WW,1);
UU2:=BACKSET(BARSTATUS,BARSLAST(hd) 1);
VV2:=UU2>REF(UU2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1) 2);
XX2:=WW2>REF(WW2,1);
前一低支撐:REF(L,BARSLAST(VV)),PRECIS2,COLOR99FF66,LINETHICK1,DOtlINE;
箱體下沿:REF(L,BARSLAST(xx)),ColorFFFF00,PRECIS2;
前一高壓力:REF(H,BARSLAST(VV2)),PRECIS2,COLOR99FF66,LINETHICK1,DOTLINE;
箱體上沿:REF(H,BARSLAST(XX2)),PRECIS2,Color00FFFF;
DRAWTEXT(nn,前一低支撐,前一低支撐: NUMTOSTRN(前一低支撐,2) 元),ALIGn2,Color00dd00,VALIGN0;
DRAWTEXT(nn,前一高壓力,前一高壓力: NUMTOSTRN(前一高壓力,2) 元),ALIGN2,Color00dd00,VALIGN2;
DRAWTEXT(nn,箱體下沿,箱體下沿: NUMTOSTRN(箱體下沿,2) 元),ALIGN2,ColorFFFF00,LINETHICK1,VALIGN0;
DRAWTEXT(nn,箱體上沿,箱體上沿: NUMTOSTRN(箱體上沿,2) 元),ALIGN2,Color00FFFF,LINETHICK1,VALIGN2;
DRAWTEXTREL(10,800,㊣十二星座*神獒贏富㊣),linethick1,COLOR00EEff;
DRAWGBK((CLOSE > 0),STRIP(rgb(4,1,28),RGB(4,1,35),0));

本文內容來自互聯網轉載,不代表本人立場,若侵犯您的權益,請聯系我們第一時間刪除,謝謝!如若轉載,請注明出處:http://www.lbzkzu.live/zixun/1f2148e3cf7347e17eba6cb9.html

標簽:

標簽:

广西快3走势图基本图